BETA

2nd August 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [02/08/18 01:51 PM] with 'Major Outage'

Issue has been resolved at [02/08/18 01:54 PM]