BETA

2nd August 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [02/08/18 12:07 PM] with 'Major Outage'

Issue has been resolved at [02/08/18 12:08 PM]