BETA

7th May 2019

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [07/05/19 01:43 AM] with 'Major Outage'

Issue has been resolved at [07/05/19 01:44 AM]