BETA

1st August 2018

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [01/08/18 07:18 PM] with 'Major Outage'

Issue has been resolved at [01/08/18 07:19 PM]