BETA

12th July 2016

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [12/07/16 11:22 AM] with 'Partial Outage'

Issue has been resolved at [12/07/16 11:25 AM]