BETA

1st August 2018

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [01/08/18 05:20 PM] with 'Partial Outage'

Issue has been resolved at [01/08/18 05:22 PM]