BETA

1st August 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [01/08/18 03:42 PM] with 'Major Outage'

Issue has been resolved at [01/08/18 03:43 PM]