BETA

1st August 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [01/08/18 03:24 PM] with 'Partial Outage'

Issue has been resolved at [01/08/18 03:26 PM]