BETA

1st August 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [01/08/18 02:57 PM] with 'Partial Outage'

Issue has been resolved at [01/08/18 03:00 PM]