BETA

11th April 2017

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [11/04/17 02:18 AM] with 'Major Outage'

Issue has been resolved at [11/04/17 02:20 AM]