BETA

1st August 2018

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [01/08/18 01:13 PM] with 'Partial Outage'

Issue has been resolved at [01/08/18 01:14 PM]