BETA

31st July 2018

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [31/07/18 12:21 PM] with 'Major Outage'

Issue has been resolved at [31/07/18 12:25 PM]