BETA

31st July 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [31/07/18 12:18 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [31/07/18 12:20 PM]