BETA

31st July 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [31/07/18 12:18 PM] with 'Major Outage'

Issue has been resolved at [31/07/18 12:19 PM]