BETA

31st July 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [31/07/18 12:00 PM] with 'Partial Outage'

Issue has been resolved at [31/07/18 12:04 PM]