BETA

6th May 2019

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [06/05/19 06:28 PM] with 'Major Outage'

Issue has been resolved at [06/05/19 06:32 PM]