BETA

30th July 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [30/07/18 01:06 PM] with 'Partial Outage'

Issue has been resolved at [30/07/18 01:07 PM]