BETA

30th July 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [30/07/18 11:52 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [30/07/18 11:54 AM]