BETA

30th July 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [30/07/18 10:42 AM] with 'Partial Outage'

Issue has been resolved at [30/07/18 10:44 AM]