BETA

11th April 2017

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [11/04/17 12:18 AM] with 'Partial Outage'

Issue has been resolved at [11/04/17 12:19 AM]