BETA

29th July 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [29/07/18 08:25 PM] with 'Major Outage'

Issue has been resolved at [29/07/18 08:27 PM]