BETA

29th July 2018

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [29/07/18 01:46 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [29/07/18 01:48 PM]