BETA

29th July 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [29/07/18 06:27 AM] with 'Partial Outage'

Issue has been resolved at [29/07/18 06:28 AM]