BETA

29th July 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [29/07/18 12:00 AM] with 'Partial Outage'

Issue has been resolved at [29/07/18 12:02 AM]