BETA

28th July 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [28/07/18 10:39 PM] with 'Partial Outage'

Issue has been resolved at [28/07/18 10:40 PM]