BETA

14th March 2019

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [14/03/19 09:25 PM] with 'Major Outage'

Issue has been resolved at [14/03/19 09:26 PM]