BETA

28th July 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [28/07/18 01:55 PM] with 'Partial Outage'

Issue has been resolved at [28/07/18 01:56 PM]