BETA

27th July 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [27/07/18 04:38 PM] with 'Partial Outage'

Issue has been resolved at [27/07/18 04:39 PM]