BETA

27th July 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [27/07/18 01:58 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [27/07/18 02:00 PM]