BETA

26th July 2018

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [26/07/18 11:54 AM] with 'Partial Outage'

Issue has been resolved at [26/07/18 12:01 PM]