BETA

26th July 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [26/07/18 11:36 AM] with 'Partial Outage'

Issue has been resolved at [26/07/18 11:37 AM]