BETA

25th July 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [25/07/18 06:32 PM] with 'Partial Outage'

Issue has been resolved at [25/07/18 06:35 PM]