BETA

25th July 2018

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [25/07/18 02:25 PM] with 'Partial Outage'

Issue has been resolved at [25/07/18 02:26 PM]