BETA

24th July 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [24/07/18 02:17 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [24/07/18 02:20 PM]