BETA

24th July 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [24/07/18 01:35 PM] with 'Partial Outage'

Issue has been resolved at [24/07/18 01:36 PM]