BETA

14th March 2019

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [14/03/19 09:18 PM] with 'Major Outage'

Issue has been resolved at [14/03/19 09:24 PM]