BETA

24th July 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [24/07/18 12:55 PM] with 'Partial Outage'

Issue has been resolved at [24/07/18 12:56 PM]