BETA

24th July 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [24/07/18 11:04 AM] with 'Partial Outage'

Issue has been resolved at [24/07/18 11:05 AM]