BETA

24th July 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [24/07/18 09:40 AM] with 'Partial Outage'

Issue has been resolved at [24/07/18 09:49 AM]