BETA

24th July 2018

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [24/07/18 02:11 AM] with 'Partial Outage'

Issue has been resolved at [24/07/18 02:12 AM]