BETA

23rd July 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [23/07/18 08:15 PM] with 'Partial Outage'

Issue has been resolved at [23/07/18 08:20 PM]