BETA

23rd July 2018

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [23/07/18 06:11 PM] with 'Partial Outage'

Issue has been resolved at [23/07/18 06:20 PM]