BETA

23rd July 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [23/07/18 05:27 PM] with 'Partial Outage'

Issue has been resolved at [23/07/18 05:29 PM]