BETA

14th March 2019

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [14/03/19 04:59 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [14/03/19 05:05 PM]