BETA

5th May 2019

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [05/05/19 06:09 AM] with 'Major Outage'

Issue has been resolved at [05/05/19 06:13 AM]