BETA

23rd July 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [23/07/18 03:14 PM] with 'Major Outage'

Issue has been resolved at [23/07/18 03:19 PM]