BETA

5th April 2017

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [05/04/17 07:28 PM] with 'Major Outage'

Issue has been resolved at [05/04/17 07:29 PM]