BETA

23rd July 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [23/07/18 12:59 PM] with 'Partial Outage'

Issue has been resolved at [23/07/18 01:00 PM]