BETA

14th March 2019

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [14/03/19 04:06 PM] with 'Partial Outage'

Issue has been resolved at [14/03/19 04:07 PM]