BETA

23rd July 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [23/07/18 10:34 AM] with 'Partial Outage'

Issue has been resolved at [23/07/18 10:37 AM]